Original Autel MaxiIM IM608

BMW ICOM D Cable technical support


Matched product:

Free shipping High Quality BMW ICOM D Cable ICOM-D Motorcycles Motobikes Diagnostic Cable with PCB [Buy SF115-C Instead]

Free shipping High Quality BMW ICOM D Cable ICOM-D Motorcycles Motobikes Diagnostic Cable with PCB [Buy SF115-C Instead]

Latest price:US$379.00
US$199.0047% off
  • Item No. SF115-B
  • Out Of Stock
This is high quality ICOM D Cable for BMW Motorcycle Diagnostic, Inside with PCB which common quality ICOM D cable not contain, Support vehicle till 2016 year.
Customer share : troubleshoot BMW Bike S1000RR with ICOM D
1.How to troubleshoot BMW Bike S1000RR with ICOM D

Here, i’d like to share some experience of programming experience of my bike s1000rr with two bmw cables. Also solutions for ISTA-D 3.48 error message : “Unable to identify vehicle”.

/upload/service/16092573196976.jpg

Bike: BMW S1000RR 2011
 
Tools i’m using: INPA K+DCAN USB cable and ICOM D adapter
With software: Rheingold (ISTA-D) v3.48
 
Laptop’s OS: Windows 7 32 bit.
 
Puzzle: I have K+DCAN cable and ICOM-D adapter but bike cannot get connected with ISTA-D 3.48. I get error: "Unable to identify vehicle. Please check vehicle communication interface and vehicle ignition (must be set to ON).”.
Ps. Same software is workinng fie with my F3x -serie car (with K+DCAN and/or ENET cable).
 
Bike and ICOM D: My s1000rr is 2011 and bike’s service plug 10 pin socket has pin 1, 4, 6 and 10 in use, no pin 2 in use. With voltage gauge I measured that signal is going through ICOM-D cable's OBD port:
10pin --> obd2
1 --> 7
4 --> 4 and 5
6 --> 16
10 --> 1
 
Here is what i did.
I have installed EDIABAS and tried to change com ports (in obd.ini) according to laptop’s usb port com etc. I have changed in laptop’s device manager latency of port to 1. Feeding additional electricity to battery with separate charger, tried engine running but not working.
 
When I try to read vechile info via Rheingold, K+DCAN cable’s little light flashes once briefly and then stops and gets the error in software.
 
SOLVED!!!
Tried time and time again with methods online. I solved my problem, at least partly.
 
I can now connect to all of my bike’s ecus and read live data, reset service indicator after service etc. Although I cannot make for example ABS unit’s bleeding (in case of I would like to change all break lines and some other this kind of jobs).
 
I removed all old stuff and re-installed software. I also downgraded USB serial driver version. I found via Google that there might be problem with Chinese cables which not necessarily have genuine FTDI chip. The newest driver versions won’t necessarily work with fake FTDI chips.
I have this kind of k+dcan cable cable:
http://www.obd2eshop.com/wholesale/bmw-inpa-k-can-with-ft232rq-chip.html
 
I cleaned com ports via Windows regedit and configured there serial port RxFIFO and TxFIFO values and put force_fifo_enable on. If I remember it correctly it was off at some point in my trials.
 
I also made own cable between bike’s 10-round pin adapter and k+dcan cable. Or actually it’s not real cable, just set of separate wires which I connect from motorcycle’s round adapter pins straight to K+DCAN cable’s pins. I haven’t tried to connect to motorcycle with icom-d cable since then so I don’t know whether it would work nowadays after other changes I made.
 
I was lazy and made many changes at the same time so root cause for my earlier problems is not totally clear.
 
I am not sure whether I should have BMW ICOM A2 entity in order to get rest of Rheingold functionalities to work. But at the moment I am happy with those functionalities I have now available.